Can I use current DICOM Viewer with your PACS?

jiun

Yes, you can.
However your current DICOM Viewer needs to have following requirements.

  • It must be compliant with the DICOM Standard.
  • It must support Study Root Query/Retrieve or Patient Root Query/Retrieve.

Regarding how to connect with our PACS, please refer to Install Manual.
Also, regarding technical information, please refer to DICOM Conformance Statement.